Mesa开发者正考虑提高Mesa驱动默认编译器最低配置要求

2021年03月29日 15:07 次阅读 稿源:cnBeta.COM 条评论

Mesa 开发者正在讨论是否提高 Mesa 驱动默认编译器最低配置要求。除非覆盖编译器 Flag,否则将会默认提高 Mesa 驱动的基础 CPU 要求,不过只有那些最老的系统才能受到影响。和其他开源项目一样,Mesa 开发者也在讨论提高 CPU 基础要求,从而使用更优化的编译器默认值,对近期的 CPU 进行优化。

访问:

2021阿里云上云采购季:采购补贴、充值返券、爆款抢先购

云通信分会场:爆款产品低至7.2折,短信低至0.034元/条

5ikajje9.jpg

本周开启的一项新提案将默认在 Mesa 版本中使用 SSE2。即使在2021年,除非特别针对它,否则 Mesa 构建中默认不使用 SSE2。SSE2 的出现可以追溯到 2000 年的 Pentium 4,而AMD的支持则是从三年后的Athlon 64时代开始的。

在 2021 年默认使用SSE2还是比较保守的,让大概二十年的 CPU 还能用 Mesa。微软 MSVC 下的 Mesa 版本也已经默认启用 SSE2,没有引起用户的反感。也有人建议在 Mesa 构建中默认启用 SSE3/SSSE3,同时也可以让 10~15 年前的硬件仍然可以在Mesa的默认构建中正常运行。

提高CPU特性基线也确实带来了在处理图形驱动等低级代码时出现新bug的可能性。有些人认为,可能会出现Gallium Nine的问题或其他需要解决的兼容性问题/小毛病。RFC将在下一季度的Mesa 21.1之后提高编译器功能基线。

对文章打分

Mesa开发者正考虑提高Mesa驱动默认编译器最低配置要求

1 (50%)
已有 条意见

    最新资讯

    加载中...

    今日最热

    加载中...

    热门评论

      Top 10

      招聘


      Advertisment ad adsense googles cpro.baidu.com
      created by ceallan