谷歌下一代Android Q将限制6.0系统以下APP的运行

2018年09月04日 08:04 次阅读 稿源:快科技 条评论

按照谷歌的命名习惯,下一代安卓系统会是Android Q(按照字母表排序),版本号或将为Android 10。据XDA报道,AOSP中出现了面向第一代安卓系统的贡献代码,其中包括一项系统级的警告特性。在运行任何应用程序时,系统都会检查其API级别,如果低于或等于23(安卓5.0棒棒糖或更老),则会弹出警告,提示可能无法正常运行。

其实在安卓9.0 Pie中就添加进这种特性了,比如基于安卓1.6(API level 4)开发的ManifestViewer应用,调用前就有弹窗警告。

谷歌之所以这么做其实还是处于安全考虑,一些开发者之所以不愿使用安卓6.0以上的配套API,主要因为后者有着更严格的权限监控。

资料显示,从今年8月1日起,所有新向Play商店提交的应用都必须基于API Level 26(安卓8.0及以上)开发,同时,今年11月后,所有Play商店的存量应用也都要遵守这一规定,否则予以下架。谷歌此举首先是保证良好的兼容性,同时,API等级越高,也可以同步谷歌在安全性、隐私性、内存优化、电池优化的最新改善。

腾讯云校园

活动入口:

腾讯云 - 热销云产品年付3折起

对文章打分

谷歌下一代Android Q将限制6.0系统以下APP的运行

3 (6%)
已有 条意见

欧美智能腕表新品发售

    最新资讯

    加载中...

    今日最热

    加载中...

    热门评论

      Top 10

      招聘


      Advertisment ad adsense googles cpro.baidu.com
      created by ceallan